orbshield + mega2560 = unworking

SpaceOrb drivers and software discussions
Post Reply
methodermis
Posts: 2
Joined: June 05 2012, 14:51 PM

orbshield + mega2560 = unworking

Post by methodermis » June 06 2012, 16:35 PM

Hello vputz! And thank you for the orbshield design, I'm looking forward to using this awesome spaceball 4000 flx but can't get the orbshield to be recognized by a computer.

I verified solder points etc. It's paired to a mega2560 and when running your serial test code it registers button presses from the spaceball, so the arduino and serial chip are working.

When the orbshield is connected to usb it is never recognized. Leonardo showed up on adafruit and I think I'll get one and see if the orbshield can be adapted to it

Also noticed orbdevice.h had to be modified (removing BYTE from two lines) to compile

B

vputz
Posts: 339
Joined: March 25 2006, 20:21 PM
Contact:

Re: orbshield + mega2560 = unworking

Post by vputz » July 02 2012, 17:04 PM

Methodermis--

Hmm! Never tried getting it to work with a mega, but I don't see why it would have trouble.

In general, when the shields have failed--and I sincerely regret that I have had a handful--it has almost always been the USB side. And sadly in many of these cases I have never been able to figure it out (I had one person send me his shield and wound up replacing every component on it with that from a known working shield--and it never did work right!)

So I don't yet have anything encouraging. If I find more free time, I'm pretty sure I can get the leonardo working, and that would be the "right" solution for the modern age--the Leo can handle USB directly and act like a joystick if we reprogram the bootloader, which I *think* will be pretty easy. I'm fairly sure that existing shields will work (although I'm not positive).

Sorry I haven't been working on this--I'm about to move back to England for a few years and work and such has been crazy. I do regret the trouble people have had with this--as always I can only come back with the lame "...but it works for me!" in most cases.

Still, I have a lot of faith in the Leo option, just need a few quiet days to dig back into it. Too many projects, too many draws on my time!

methodermis
Posts: 2
Joined: June 05 2012, 14:51 PM

Re: orbshield + mega2560 = unworking

Post by methodermis » July 31 2012, 20:29 PM

Thank you for the reply!
No luck getting the mega to work. I ordered a Duemilanove and they sent me an Uno. The orbshield library won't compile on the new arduino software however :(

vputz
Posts: 339
Joined: March 25 2006, 20:21 PM
Contact:

Re: orbshield + mega2560 = unworking

Post by vputz » August 08 2012, 11:10 AM

Grr, grr... I'm SO sorry about that. It's been a helluva year and I'm moving overseas to London in three weeks so I haven't had time to update that. It's a TOTALLY minor fix (this is where the compiler complains about BYTE, right?). Okay, I'm going to try and take some time tonight to make that change and upload it.

Seeed is still out of kits, and I still haven't had time to do the rewrite, but my hope (sad hope in a sense) is that after moving while I'm still in that "no friends here, nothing to do on weekends" mode I can catch up on these projects.

Post Reply