Search found 31 matches

by adamh128
May 10 2012, 13:15 PM
Forum: Spaceware Software
Topic: Orbshield Not Working :cry:
Replies: 41
Views: 20500

Re: Orbshield Not Working :cry:

That would be great, it's been many years since I've been able to play with my orb :wink:
by adamh128
May 07 2012, 12:38 PM
Forum: Spaceware Software
Topic: Orbshield Not Working :cry:
Replies: 41
Views: 20500

Re: Orbshield Not Working :cry:

[quote="Sparky"]I had the same issues. I replaced the diodes and resistors and used version 022 with the WASD sketch and it worked. My soldering iron may have been a little too hot or I left it on the soldering point a little too long. Maybe damaged te diodes or resistors? Either way, it's working w...
by adamh128
March 28 2012, 3:21 AM
Forum: Spaceware Software
Topic: Orbshield Not Working :cry:
Replies: 41
Views: 20500

Re: Orbshield Not Working :cry:

I did have to modify one of the header files to get it to compile on 1.0 as the API had changed slightly...



Just needed to change Serial.print( ... , BYTE) to Serial.write( ... )
by adamh128
March 27 2012, 15:09 PM
Forum: Spaceware Software
Topic: Orbshield Not Working :cry:
Replies: 41
Views: 20500

Re: Orbshield Not Working :cry:

I just tried again with the latest software (Arduino 1.0) but the same thing... When first plugging USB into the shield, in device manager window it shows "Other devices" -> "Spaceorb/Spaceball", but then that disappears and now in "Human Interface Devices" I get "USB Input Device" with an exclamati...
by adamh128
March 27 2012, 14:19 PM
Forum: Spaceware Software
Topic: Orbshield Not Working :cry:
Replies: 41
Views: 20500

Re: Orbshield Not Working :cry:

Unfortunately I cannot try the Arduino 018 version as support for the Uno was not introduced until version 020.

I am downloading 023 and version 1.0, but I'm not holding my breath.
by adamh128
March 26 2012, 13:57 PM
Forum: Spaceware Software
Topic: Orbshield Not Working :cry:
Replies: 41
Views: 20500

Re: Orbshield Not Working :cry:

I'm beginning to think my problems are down to my use of the UNO - I'm tempted to buy a Duemilanove and give that a try.

Where did you get yours from - the places I can find it online all look rather dodgy.
by adamh128
June 17 2011, 12:59 PM
Forum: Spaceware Software
Topic: Orbshield Not Working :cry:
Replies: 41
Views: 20500

Re: Orbshield Not Working :cry:

Just wondered if you'd had any luck reproducing my problem with your Uno?



Also, please PM me your address so I can return your shield!



Thanks,

Adam
by adamh128
May 05 2011, 7:09 AM
Forum: Spaceware Software
Topic: Orbshield Not Working :cry:
Replies: 41
Views: 20500

Re: Orbshield Not Working :cry:

Hi Victor, Not sure if you're busy - I sent a you PM a while ago, but maybe it didn't get delivered, so I'll reproduce it here... [quote]Well the shield arrived... but it behaves the same as my original one However, all is not lost - I've been playing around uninstalling drivers, trying different po...
by adamh128
March 13 2011, 6:05 AM
Forum: Spaceware Software
Topic: Orbshield Not Working :cry:
Replies: 41
Views: 20500

Re: Orbshield Not Working :cry:

If I connect the shield to the Uno, I get the following:



-A, +B : 15K

+A, -B : 3K

-C, +D : 11k

+C, -D : 3k



Unfortunately I don't have access to a scope otherwise we could have a stab at fault-finding.
by adamh128
March 12 2011, 14:57 PM
Forum: Spaceware Software
Topic: Orbshield Not Working :cry:
Replies: 41
Views: 20500

Re: Orbshield Not Working :cry:

I've just put a multimeter across the diodes (I'm not sure this is a valid test with all the components on board). Using the test points as shown in the attached image (this is my OrbShield BTW), I measured the resistance across D1 and D2 with the following results: (-) probe on A, (+) probe on B: 3...
by adamh128
March 12 2011, 14:26 PM
Forum: Spaceware Software
Topic: Orbshield Not Working :cry:
Replies: 41
Views: 20500

Re: Orbshield Not Working :cry:

[quote]Here it is. Just a Real Simple test program; load it up and then turn the serial monitor on (Tools->Serial Monitor). You should see data flow whenever the orb does something.[/quote] Yea, I get lots of data that changes when I press the orb buttons or ball. [quote]Hey, any chance you accident...
by adamh128
March 12 2011, 11:35 AM
Forum: Spaceware Software
Topic: Orbshield Not Working :cry:
Replies: 41
Views: 20500

Re: Orbshield Not Working :cry:

[quote]Have you tried the OrbSerialTest sketch? [/quote]
I do not seem to have this, all I have is:
[list]
  • [*]BasicJoystick
  • [*]GainDemo
  • [*]WASD
  • [/list]
    by adamh128
    March 10 2011, 15:10 PM
    Forum: Spaceware Software
    Topic: Orbshield Not Working :cry:
    Replies: 41
    Views: 20500

    Re: Orbshield Not Working :cry:

    [quote="adamh128"]I just bought a second-hand orb on ebay with firmware version 4.34 - so once it arrives I'll be able to tell for sure if the issue is down to my original orb (and the old firmware) or if it's a problem with the shield.[/quote] Well, the orb arrived but I have the exact same problem...
    by adamh128
    March 06 2011, 12:23 PM
    Forum: Spaceware Software
    Topic: Orbshield Not Working :cry:
    Replies: 41
    Views: 20500

    Re: Orbshield Not Working :cry:

    Does anyone actually know what the difference is in the firmware versions - I'm wondering why the older firmware orbs don't work with the hidsporb drivers?



    I've just been playing with the old libOrb library and it works perfectly well with my older orb.
    by adamh128
    March 06 2011, 7:01 AM
    Forum: Spaceware Software
    Topic: Orbshield Not Working :cry:
    Replies: 41
    Views: 20500

    Re: Orbshield Not Working :cry:

    I just bought a second-hand orb on ebay with firmware version 4.34 - so once it arrives I'll be able to tell for sure if the issue is down to my original orb (and the old firmware) or if it's a problem with the shield.

    Go to advanced search